11 Comments

  1. orhan

    composer install kısmında bu hatayı alıyorum. yardımcı olabilirmisiniz

    //*

    [Composer\Exception\NoSslException]
    The openssl extension is required for SSL/TLS protection but is not available. If you can not enable the openssl ex
    tension, you can disable this error, at your own risk, by setting the ‘disable-tls’ option to true.

    install [–prefer-source] [–prefer-dist] [–dry-run] [–dev] [–no-dev] [–no-custom-installers] [–no-autoloader] [–no-scripts] [–no-progress] [–no-suggest] [-v|vv|vvv|–verbose] [-o|–optimize-autoloader] [-a|–classmap-authoritative] [–apcu-autoloader] [–ignore-platform-reqs] [–] []…

    *//

    • Ahmet Ertem

      Bu hatayla hic karsilasmadim fakat internette arastirdigimda Windowsta olusan Open SSL hatasi oldugunu gordum. Hatayi duzeltmek icin php.ini dosyasini acip (notepad++ ile acarsan daha saglikli olur) <em>#extension=php_openssl.dll</em> satirini bulup onundeki diez isaretini kaldirman ve ardindan XAMPP/WAMP kullaniyorsan control programi ile apache ye restart atman gerekiyor Orhan

  2. Ddd

    Projenin ana dizinine composer.json dosyasi olusturmak gerekiyor diyo kardesim bu projenin ana dizini neresi bi aciklamamissiniz yav nereye olusturcaz bunu www klasoru icine ise eger olmuyor nerde bu ana dizin

  3. osman

    slm kardes ben dediğin gibi yaptım ama ben wampserver kullanıyorum dosyaları www yani projemin ana dizininde olsuturmuyo C:Usersmehmet> komut satırında bu dizin cıkıyo ve buraya yukluyo napmam lazım www içine yuklemesi için

  4. selcukaydin

    C:Userslenovo>curl -sS https://getcomposer.org/installer | php

    Fatal error: Directive ‘magic_quotes_gpc’ is no longer available in PHP in Unknown on line 0
    curl: (23) Failed writing body (0 != 16133)

    yukarıdakini yaptığım zaman bu geliyor. PATH’leri ekledim. anladığım kadarıyla php versiyonum desteklemiyor. Acemiyim 15 yıldır weble kodla uğraşmadım fazla. anladımki çok şey değişmiş. Solucan sürüsü gibi kodlama gelişmiş. :D

    • Ahmet Ertem

      Merhabalar,

      Normalde 5.5+ hatasiz calismasi gerekmekte fakat sizin de soylediginiz gibi versiyonunuz eski oldugu icin paket uyumsuzlugu oluyor olma ihtimali cok yuksek.

      Bence XAMPP’i yedek alin ve tekrar deneyin;
      …\xampp\htdocs (klasor)
      …\xampp\php\php.ini
      …\xampp\mysql\data (klasor)

      Oncelikle servisleri durdurun (XAMPP kontrol panelinden) ve varsa servis, silin.

      Yukarida belirrtigim dosya ve klasorlerin yedegini alip, yeniden kurulum yapin. Bir problem yasamamak icin bence tum XAMPP dizinini yedek almaniz daha saglikli (sahsen oyle yapiyorum).

      Yeniden kurulum yaptiktan sonra tekrar deneyiniz.

      Iyi calismalar

  5. selcukaydin

    The PHP exe file you specified did not run correctly:
    E:xamppphpphp.exe

    Reported error: Yanlış işlev

Leave a Reply to orhan Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.